У текущего пользователя нет доступных ролей, для запуска информационной базы

Автор: Admin

Дата:2012-08-09

Эта ошибка возникает при добавлении нового пользователя с новой ролью.

Например иногда необходимо в бухгалтерию добавить пользователя занимающегося кадрами и поэтому нужно для него создать новый интерфейс и роль "кадры". После чего присваиваем новую роль пользователю и пытаемся войти в 1С. Но не тут то было и 1С нам говорит, что "У текущего пользователя нет доступных ролей, для запуска информационной базы"

Для избежания этого необходимо немножко дописать в конфигураторе.

Общие - Общий модуль -УправлениеПользователями

Процедура ПроверитьВозможностьРаботыПользователя(Отказ) Экспорт
    Если НЕ РольДоступна("ПолныеПрава") И НЕ РольДоступна("Бухгалтер") И НЕ рольДоступа("Кадры") Тогда
        Отказ = Истина;
        #Если Клиент Тогда
        Предупреждение("У текущего пользователя нет доступных ролей, для запуска информационной базы.", 10, "Недостаточно прав доступа");
        #КонецЕсли
    КонецЕсли;    
КонецПроцедуры


После чего, применяем новую конфигурация и спокойно заходим в 1С.

Однако есть и одно но - это обновление конфигураций, после которого может произойти затирание этой записи.

Количество просмотров: 6905

Комментарии к статье:

Автор комментария: Марина
Дата: 2016-03-27

Спасибо, помогло

Автор комментария: Вика
Дата: 2015-12-28

Я лубю танцы

Автор комментария: Вика Орлова
Дата: 2015-12-28

Я лублю петь нмьыдьмооабролгьзззыыыыд тпььмгь молчпао таниц руг

Добавить комментарий

Введите сумму с картинки

© Plutonit.ru - Администрирование, настройка Linux и Windows 2009 - 2017