Печать старой и новой цены в 1с 7.7 (Ценник)

Автор: Admin

Дата:2012-02-19

Печать старой и новой цены в 1с 7.7

В розничном магазине очень часто происходит переоценка товара и необходимо эту переоценку показать в виде новой цены и старой цены, которая была до переоценки. Если у Вас еще нет программы 1С, то вы можете купить 1с по доступной цене.
В 1С 7.7 за это отвечает документ "переоценка (розница)" и соответственно печатная форма ценника, которая по умолчанию печатает только новую цену, уже переоцененного товара.
Давайте исправим эту ситуацию.
Нам необходимо найти в каталоге 1С  printcen.ert по пути:
\ExtForms\PrnForms\printcen.ert
и сделать копию
\ExtForms\PrnForms\printcen-pereocenka.ert

1 ЧАСТЬ - Работа с модулем

Открываем в режиме конфигуратора и ищем строчки
Процедура ДобавитьЦенник(Таб, Фирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд) Экспорт
Добавляем "СтараяЦена"
Процедура ДобавитьЦенник(Таб, Фирма, ПечНаименование, ПечЕдиница, ПечРозн,
СтараяЦена, Столбик, Ряд) Экспорт

Далее идем вниз
Процедура Печать(Докум, Устройство=0, КолвоКопий=1) 
    ДокумВид = Докум.Вид();
    Если ДокумВид = "ПереоценкаРозница" Тогда
        ИдРознЦена = "ЦенаНовая";
    

Получаем:
Процедура Печать(Докум, Устройство=0, КолвоКопий=1) 
    ДокумВид = Докум.Вид();
    Если ДокумВид = "ПереоценкаРозница" Тогда
        ИдРознЦена = "ЦенаНовая";
        ИдРознЦена1 = "ЦенаСтарая";


Идете еще ниже и находим
Докум.ВыбратьСтроки();
     Пока Докум.ПолучитьСтроку() = 1 Цикл
        Если ДокумВид = "ПереоценкаРозница" Тогда
             Если Докум.ЦенаСтарая = Докум.ЦенаНовая Тогда
                 Продолжить;  
             КонецЕсли;
         КонецЕсли;
         ВремЦена = Докум.ПолучитьАтрибут(ИдРознЦена);  
        
ПечРозн    = глФРМ(ВремЦена, глРубли);
       
ПечНаименованиеТМЦ = СокрЛП(Докум.Номенклатура.ПолнНаименование) + ?(Константа.ПоказыватьАртикул = 1, " " + СокрЛП(Докум.Номенклатура.Артикул), "");
        ДобавитьЦенник(Таб, Докум.Фирма, ПечНаименованиеТМЦ, Докум.Единица, ПечРозн, Столбик, Ряд);
         глОживить(1);

Заменить на:
Докум.ВыбратьСтроки();
     Пока Докум.ПолучитьСтроку() = 1 Цикл
        Если ДокумВид = "ПереоценкаРозница" Тогда
             Если Докум.ЦенаСтарая = Докум.ЦенаНовая Тогда
                 Продолжить;  
             КонецЕсли;
         КонецЕсли;
         ВремЦена = Докум.ПолучитьАтрибут(ИдРознЦена);  
         ВремЦена1 = Докум.ПолучитьАтрибут(ИдРознЦена1);
        ПечРозн    = глФРМ(ВремЦена, глРубли);
        СтараяЦена    = глФРМ(ВремЦена1, глРубли);
        ПечНаименованиеТМЦ = СокрЛП(Докум.Номенклатура.ПолнНаименование) + ?(Константа.ПоказыватьАртикул = 1, " " + СокрЛП(Докум.Номенклатура.Артикул), "");
        ДобавитьЦенник(Таб, Докум.Фирма, ПечНаименованиеТМЦ, Докум.Единица, ПечРозн, СтараяЦена, Столбик, Ряд);
         глОживить(1);


2 ЧАСТЬ - Работа с таблицей

Переходим в Таблица
Добавляем новое выражение <СтараяЦена> - тип выражение
Зачеркнуть можно при помощи "Линия"

Печать две цены


3 ЧАСТЬ - Добавляем обработку в документ Переоценка (Розница)
После чего необходимо добавить эту обработку в документ Переоценка (Розница)
Сервис - регистрация внешних печатных форм - изменить - внести в список.
Находим новую обработку с именем printcen-pereocenka.ert, указываем название (ценник 2 цены)
И все теперь можно из документа
Переоценка (Розница) печатать цену старую и новую.

Печать ценников в 1с 7.7

Количество просмотров: 9296

Комментарии к статье:

Автор комментария: рома
Дата: 2014-03-25

а как сделать ценник с оптовой и розничной ценой?

Автор комментария: Татьяна
Дата: 2013-03-10

Добрый день я бы отела узнать как в 1с7.7 9.2 вывести штрихкод на ценник я сказала файл EanBwrP36TtNormal.Ttf теперь не знаю что дальше делать?

Автор комментария: Серж
Дата: 2012-03-02

Спасибо очень подробно

Добавить комментарий

Введите сумму с картинки

© Plutonit.ru - Администрирование, настройка Linux и Windows 2009 - 2017